PHP 5.3.x bei Hosteurope auf einem Virtual Server Managed

Könnte man einen Server selber konfigurieren und einrichten, würde man für weniger Geld viel mehr Leistung bekommen. Kann oder will man das aber nicht, ist man auf den Support angewiesen – in diesem Fall auf den Support von Hosteurope, den ich fragte, ob und wann PHP 5.3.x zur Verfügung stehen wird.

Meine Anfrage vom 9.September 2011:

„ich betreibe mehrere TYPO3 Projekte auf meinem Webspace. Im Oktober wird nun die neue TYPO3 Version 4.6 erscheinen, die zwingend php 5.3 benötigt.
Momentan läuft jedoch nur php 5.2.17. Daher meine Frage: ist es auf meinem Server möglich auf php 5.3 umzustellen? Bzw. welche anderen Möglichkeiten gibt es?

Antwort von HE:

vielen Dank für Ihr Interesse, die neue PHP Version vor der offiziellen Einführung zu testen.
Gerne werden wir Ihnen PHP in Version 5.3.6 im Rahmen eines Beta Tests auf Ihrem Virtual/Dedicated Server Managed zur Verfügung stellen. Bitte bestätigen Sie uns per Antwort auf diese E-Mail, dass Sie die im folgenden aufgeführten Hinweise zur Kenntnis genommen haben und sich damit einverstanden erklären:
– Die Bereitstellung von PHP 5.3.6 erfolgt im Rahmen eines Beta Tests und auf Ihren ausdrücklichen Wunsch
– Da der Suhosin Patch für die PHP Version 5.3.6 noch nicht zur Verfügung steht, kann es für Dritte möglicherweise einfacher sein, eventuell vorhandene Sicherheitslücken in Ihren Skripten auszunutzen
– Trotz vorheriger Tests kann es, bedingt durch die neue Version, zu Fehlern im laufenden Betrieb kommen
– Die Behebung von Fehlern kann sich aufgrund der aufwändigeren Fehlersuche verzögern
– Innerhalb der Geschäftszeiten kann jederzeit wieder die vorherige PHP Version installiert werden
– Der Interpreter in Ihren Skripten muss auf /usr/bin/php5.3 angepasst werden, damit das Skript mit PHP 5.3.6 interpretiert wird. Dies betrifft in der Regel jedoch nur Skripte, die per Cronjob ausgeführt werden sowie CGI-Skripte
– Folgende Module sind bisher ausschließlich und auf Widerruf nur für PHP 5.3.6 verfügbar:
– geoip
– intl
– Falls Sie bisher APC, XCache oder EAccelerator verwendet haben, werden wir dies auch für PHP 5.3.6 aktivieren. Falls Sie das nicht wünschen, teilen Sie uns dies bitte in Ihrer Antwort mit
Sobald Sie uns Ihr Einverständnis gegeben haben, werden wir die Umstellung vornehmen und Sie im Anschluss daran informieren.

meine Antwort:

Hallo,
was genau meinen Sie mit „vor der offiziellen Einführung .. testen“?
Aktuelle Version ist PHP 5.3.8, oder verstehe ich da etwas falsch?
Vielen Dank für Ihre Auskunft.

Antwort von HE:

D.h. dass wir PHP 5.3.x noch nicht offiziell anbieten, jedoch auf einem Virtual/Dedicated Server Managed auf Wunsch aktivieren können.
5.3.8 ist erst seit dem 23.08.2011 verfügbar, da wir PHP selbst kompilieren und vor dem Ausrollen testen, dauert es noch etwas bis diese Version direkt verfügbar sein wird. Wir bieten aktuell PHP 5.3.6 an. „Beta“ bedeutet in diesem Fall, dass es nur auf Wunsch angeboten wird bis wir offiziell von 5.2.17 auf 5.3.x umstellen.

meine Antwort:

ok. vielen Dank für die Info.
Wann wird denn hosteurope offiziell auf php 5.3.x umstellen?
Grüße,

Antwort von HE:

Die offizielle Einführung von PHP 5.3.x spätestens im 1. Quartal 2012 geplant.

Am 2. März habe ich dann nachgefragt, ob der Termin „spätestens im 1. Quartal 2012′ noch steht:

gilt diese Angabe zur Einführung von PHP 5.3 noch?
Vielen Dank für eine kurze Info

Antwort von HE:

Die Angaben zur Einführung von PHP5.3 sind aktuell unverändert und sollen wie von den Kollegen beschrieben im lauf des ersten Quartals bereit gestellt werden.

Am 27.4., also nach Ende des 1. Quartals 2012, fragte ich per Antwort auf die letzte Mail folgendermaßen bei HE an:

Hallo,
kann ich also nun PHP 5.3 auf meinem Webspace verwenden bzw. aktivieren? Wenn ja, was muss ich machen?
Grüße,

Antwort von HE:

vielen Dank für Ihr Interesse, die neue PHP Version vor der offiziellen Einführung zu testen. Gerne werden wir Ihnen PHP in Version 5.3.10 im Rahmen eines Beta Tests auf Ihrem Virtual/Dedicated Server Managed zur Verfügung stellen. Bitte bestätigen Sie uns per Antwort auf diese E-Mail, dass Sie die im folgenden aufgeführten Hinweise zur Kenntnis genommen haben und sich damit einverstanden erklären:

Also genau der gleiche Text wie bereits im September 2011 (s.o.).

Meine Antwort:

die selbe Antwort hatte ich von Ihnen bereits im September 2011 bekommen. Auf meine Nachfrage teilten Sie mir damals mit:
„Die offizielle Einführung von PHP 5.3.x spätestens im 1. Quartal 2012 geplant“.
Diesen Termin hatten Sie auf meine Nachfrage hin am 2.März 2012 nochmals bestätigt. Offenbar ist PHP 5.3 bei hosteurope aber immer noch im Beta Stadium, oder sehe ich da etwas falsch?

Antwort von HE:

Aufgrund technischer Umstände ist ein Abschluss der Beta-Phase noch nicht erfolgt. Sollten Sie allerdings trotzdem PHP 5.3.x auf Ihrem Server nutzen wollen, steht einer Aktivierung Unsererseits nichts im Wege.

Hm. Ich antwortete wie folgt:

wann rechnen Sie denn mit dem Abschluss der Beta-Phase? Ich lasse mich ungern auf „Beta-Tests“ ein, wenn ich mich – wie hier – mit der Materie zu wenig auskenne. Wenn ich mich auskennen würde, bräuchte ich keinen Managed Server.

Antwort von HE:

–>“Beta“ bezieht sich nicht auf die PHP-Version selbst, sondern darauf, dass es nicht offizieller Bestandteil der Virtual Server Managed Reihe. Viele Kunden nutzen PHP 5.3 auf Virtual Server Managed Paketen.

Meine Frage:

wird denn PHP 5.3 irgendwann „offizieller Bestandteil der Virtual Server Managed Reihe“ oder nicht? Und wenn ja, wann?

Antwort von HE:

PHP 5.3.10 wird zukünftig nur noch mit PHP 5.3.10 ausgeliefert. Ob alle VSM und DSM Kunden zwangsweise auf PHP 5.3.10 umgestellt werden, steht im Moment noch im Raum. Aktuell kann der Kunden bei allen Managed Hosting Produkten (WebPacks, Virtual Server Managed, Dedicated Server Managed) selber wählen welche PHP Version er nutzt.
Hiermit hat der Kunde die Möglichkeit testweise 5.3.10 zu nutzen. Wenn alle seine Scripte problemlos weiterlaufen kann er sein Produkt auf diese Version belassen, wenn nicht kann der Kunde Problemlos zurück wechseln.

 

2 Gedanken zu „PHP 5.3.x bei Hosteurope auf einem Virtual Server Managed

  1. paul

    „PHP 5.3.10 wird zukünftig nur noch mit PHP 5.3.10 ausgeliefert“ haha! Ansonsten leider traurige Geschichte. Schade, Hosteurope

  2. Matthias

    Kleiner Nachtrag: am 15.8.2012 bekam ich eine Mail von hosteurope:
    “am Mittwoch, den 05.09.2012, werden wir in der Zeit zwischen 07:00 Uhr und 9:00 Uhr Wartungsarbeiten durchführen.

    Im Rahmen der Wartungsarbeiten werden wir die PHP Version von PHP 5.2 auf PHP 5.3 aktualisieren.


    So geschah es und es funktioniert.

Kommentare sind geschlossen.